Parking Brake Won't Release

  • Hit it once with PB and will do again tomorrow. The only thing that hits that area is the hose. I'd never take a pressure washer to a vehicle! lol

    Ah ok makes sense now. 2017 had way less recalls than the earlier ones did.

    The WORST thing that you can do to a motorcycle is use a pressure washer on it, I AGREE

  • Try some penatrating oil like Kroil or Sili Kroil. Spray down and tighten the nut and tap, I SAID TAP on the assembly with a metal object, spray down and do the same thing the next day and it just might loosen up. WD-40 does not count as pentrating oil the only thing WD-40 is good for is cleaning your hands.

    Kroil is good stuff. I combine it with Deep Creep and it eats through anything. It might take a few applications and a few hours but it always works.


    (Not for human consumption.)

    Remember folks - this isn't a rehearsal, it's The Show!8)

  • That's good advice, and I have done this as I've worked on the SS over the years. The loose nut was from me loosening it to test. Only then I noticed the mechanics at fault here which i didn't pick up before..

    probably a good idea to double check the mechanics work. They have been known to forget stuff. Get distracted. Hey look at this. Can you fix that.

  • This is now fixed! I detached the cable and removed the plate and rubber boot. So you can't spray inside w/o doing this as the rubber boot prevents anything from getting in.


    Took a couple hours of spraying and tightening/loosening with the nut, and eventually by hand to work the rust out as the bolt doesn't come out. Maybe it does on the side with the caliper, but I didn't feel like removing the wheel and fiddling with that. Brake back to working perfect and didn't have to spend anything!


    Thanks everyone for your help.

  • This is now fixed! I detached the cable and removed the plate and rubber boot. So you can't spray inside w/o doing this as the rubber boot prevents anything from getting in.


    Took a couple hours of spraying and tightening/loosening with the nut, and eventually by hand to work the rust out as the bolt doesn't come out. Maybe it does on the side with the caliper, but I didn't feel like removing the wheel and fiddling with that. Brake back to working perfect and didn't have to spend anything!


    Thanks everyone for your help.

    We all like to 'help you spend YOUR money' also. Glad it's working well. I never (almost never) set the parking break. I park and leave the Slingshot in 1st gear. On a hill may turn the wheel into the curb. At home in garage always 1st gear. Only time put away wet is if I'm coming in and it's raining.

  • A 2020 has to have the brake set when you shut down and the Autodrive is supposed to be in neutral.

    One more reason I like my 2016. Early on there was trouble when the parking break was set and left on for an extended period of time. Don't know if they have changed the system much.