Turn signal issue

Attention Vendors. Please email robert@rabtech.com any instruction manuals you may have for your products. They will be added to the FILEBASE tab for members to access.
  • I installed sequencial turn signals in my fenders. Everything worked as it’s supposed to for over two weeks. Yesterday morning it was low 50s. I hooked up my heated jacket and gloves, opened the neutrino app and started down the road. My turn signals wouldn’t work and the dash indicator stayed lit steady. I shut the motor off and restarted it. Still wouldn’t work. I turned around and parked and took my truck. When I got home 9 hours later I went to see what was going on. I hooked up everything as I did in the morning and tried every combination of hooking and un hooking the gear, the app, the phone charger.....the turn signals worked perfectly and I could not Make them stop working. Any ideas?

  • Your electricity likely got gummed up in the wires in the cold weather and wouldn't work until it got warmed up. You are probably using the wrong electricity for your area this time of year. Have you thought a bout using an Optima battery? They come in different colors for different climates.


    Seriously (it's tough for me), I'd say software glitch with the neutrino.

    Remember folks - this isn't a rehearsal, it's The Show!8)

  • Every single (cheap)led mod that I have seen has worked for a very short amount of time and then has gone to create issues with stock electronics.


    You got lucky that nothing was damaged but now you have a warning, if I was you I would listen to the SS and yank those sequential lights out before permanent ( catastrophic) damage occurs.

    Is not that I am mean, I just don't sugarcoat what I say.

  • Your electricity likely got gummed up in the wires in the cold weather and wouldn't work until it got warmed up. You are probably using the wrong electricity for your area this time of year. Have you thought a bout using an Optima battery? They come in different colors for different climates.


    Seriously (it's tough for me), I'd say software glitch with the neutrino.

    I’ll never think of a money wasting optima battery ever again in my life. I see no reason.....unless they make them last at least 5-6 years. Regular lead acid batters have worked wonderful since......The lead–acid battery was invented in 1859 by French physicist Gaston Planté and is the earliest, yet still most widely used.


    It could be the chinese sequencial boxes....

  • I’ll never think of a money wasting optima battery ever again in my life. I see no reason....

    I knew that:P

    Regular lead acid batters have worked wonderful since.....

    I knew that:P

    The lead–acid battery was invented in 1859 by French physicist Gaston Planté and is the earliest, yet still most widely used.

    I didn't know that ?(

    It could be the chinese sequencial boxes....

    I was wondering. That's why I asked if you had mytoy 's setup. It's well known that German engineering is superior...

    Remember folks - this isn't a rehearsal, it's The Show!8)