Hahn SST TurboSystem Group Buy

  • Is it true that everyone got the group buy discount but no one got an additional discount for late delivery? Or did I misinterpret?

    He has totally clammed up about that! I do believe it was 5% per week if he was later than the 30 days. Someone let his mouth override his a$$ on that one.

    My paint is fast, TURBO Silver!

    Edited once, last by maverick5990 ().

  • Fingers crossed but looks like a joint effort paid off... so far no more smoke. Very simple solution.


    Simple fix, will post it up once I completely verify it. Jersey weather not cooperating to make test drives.

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS:

  • Fingers crossed but looks like a joint effort paid off... so far no more smoke. Very simple solution.


    Simple fix, will post it up once I completely verify it. Jersey weather not cooperating to make test drives.

    Holding my breath (figuratively) in hopes for your success!
    I don't read the National Enquirer, but I do want to know! Did Elvis have anything to do with your smoke issue? I think I read he was at the helm of the Exxon Valdez when it ran aground off Alaska all those years ago. :D

  • LOL... I'm testing mine today. I didn't have anywhere near as much smoke as @Casey_SS, but a little. So got the fix done and going out for a ride today. I'll add that @WrongWheelDrive did not have smoke, but his configuration has two differences from Casey_SS and I. It has been interesting.

    :00000436:
    Success is a lousy teacher. It seduces smart people into thinking they can't lose. - Bill Gates

  • I never had any smoke on all my start/stop cycles or driving but I did go ahead and do the "fix" so I wouldn't have it pop up in the future. I was very happy with the fit and finish of everything and Bill was always available for question during the install. I want to send a huge thank you to @SaltyClownNY for coming over and helping with all the wiring it came out great.


    I'll just leave these pictures here... :evil:


  • Its not a secret... just wanting to proof it out. If its slightly off or not right then it will need to be reposted.Don't want to post bad info


    I hear you, but a lot of us have been on this journey in a virtual sense with you guys since the beginning, trying to help figure out issues, assisting with install questions, etc. Now that there is a “fix” that didn’t come from us, I assume came from the interestingly quiet Bill Hahn, everyone wants to get tight-lipped and act like this information needs to be verified and vetted before being released to the “public”

  • I hear you, but a lot of us have been on this journey in a virtual sense with you guys since the beginning, trying to help figure out issues, assisting with install questions, etc. Now that there is a “fix” that didn’t come from us, I assume came from the interestingly quiet Bill Hahn, everyone wants to get tight-lipped and act like this information needs to be verified and vetted before being released to the “public”

    Fine... I'll tell you...


  • Its not a secret... just wanting to proof it out. If its slightly off or not right then it will need to be reposted.Don't want to post bad info

    in a sense it doesn't matter whether it is right or wrong but holding back at this point is rather bad form.


    So get on with it and spill the beans :00002448:

    Proud owner of an Ultra Super Duper Faster than Light Red.

  • LOL... I'm not saying nothing. It was a solution that happened as we all 3 had the same install with just a bit of a difference and the amount of work John ( Casey_SS ) and Bill put into it, it's their story to tell. I just did my job to confirm it. I did have a "burn off" of sorts where smoke was real bad and I haven't had it sense. So up to Bill or John in my opinion. Will probably spark some additional conversations and I'd like to see some history and see if it comes back over the next few months. Until then, I'm up and running and learning the AEM software and pulling graphs and charts. Bill has been looking at them for any anomalies and he's also coming out with a new tune file at some point... that may take a while though :POKESS:


    ... none the less, I'm up and running. Took it out for a spin last night. We live in the country, so drove 20 minutes to get to a long strait road and ran it in all gears. Hard when you are hitting 80mph at the end of 3rd gear, so that 4th needed a bit more road.


    Although Bill provided support and a fix, I have to say thank you to @Casey_SS as all the hard work and aggravation was probably put on him.

    :00000436:
    Success is a lousy teacher. It seduces smart people into thinking they can't lose. - Bill Gates

  • Sorry for holding back... I'm at this point about 98.314159265359% sure we got it.


    After working with Bill and even checking my engine to make sure it was not the problem of which I know its not.


    Here is a rundown of what was checked:


    • Oil pressure (not over pressure situation)
    • Blow by using a catch can off the PCV port on the the Portfueler intake
    • Verified no intake runner leak to PCV / oiler port (this would cause oil to be sucked into the engine via cylinder 2 or 3 as the port is between the two)
    • Checked spark plug condition
    • Double checked oil level
    • Reduced oil level in engine by 1/2 quart for smoke testing
    • Swapped in a new Turbo
    • Drilled out block fitting to make smooth straight thru (totally not required, grasping at straws)
    • Checked flow of the turbo drain line numerous time
    • Checked oil flange / fittings on turbo for obstruction
    • Made sure turbo center was level
    • Engine compression check (160 lbs x 4 cyl)




    Then @SaltyClownNY having some smoke and he has my exact same sling, year, color, even WP duel exhaust. But I won the smoke amount contest LOL
    @WrongWheelDrive has same year, same Hahn setup except he's configured for 2x power and he's NOT running WP duel exhaust.


    Still working to determine why @WrongWheelDrive is not smoking. Not sure yet if its the 2x boost (which I doubt) or possibly the scavenging effects of having the longer WP Duel exhaust that both @SaltyClownNY and I have. Verses the Hahn exhaust that is very short and possibly no scavenging effects. My thoughts are that the scavenging might be creating just enough pull on the exhaust to back up the oil in the turbo oil drain. By adding the PCV valve the crankcase pressure differential is neutralized and allows the oil to flow by gravity not hindered by any +/- pressure in the crankcase.
    Again the above is my uneducated wild ass guess, but so far so good.


    Got together with Bill again as he's been completely involved with my trouble shooting. Bill came to the conclusion that it's most likely a PCV issue.


    Bill researched the most appropriate PCV valve to use which is a NAPA 2-9207 and provided the attached PDF.
    The pictures below are my installation of the PCV valve. The 90 degree barb off the intake manifold puts the PCV in a vertical position that is easy to service and out of the way of the brake reservoir.


    So far no smoke


    Bill's drawing Hahn_SS_PCV.PDF





    Hahn_SS_PCV.PDF

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS:

  • Thanks for posting the solution. Research shows that the stock intake manifold has small orifices/holes that are designed so the PCV system works correctly on this engine. With a very different design on a sheet metal intake, it would make sense that this was possibly overlooked and creating problems.

    What I don't get is why this problem wasn't known previously and why the fix/parts weren't included in the Port Fueler kit? How could this be the first time the issue has occurred?

    Glad you got it running correctly and were able to help out other SS owners!

    Owner of Slingshot #263 that has some stock parts left on it. :D

  • Thanks for posting the solution. Research shows that the stock intake manifold has small orifices/holes that are designed so the PCV system works correctly on this engine. With a very different design on a sheet metal intake, it would make sense that this was possibly overlooked and creating problems.


    What I don't get is why this problem wasn't known previously and why the fix/parts weren't included in the Port Fueler kit? How could this be the first time the issue has occurred?


    Glad you got it running correctly and were able to help out other SS owners!

    I believe I know the answer, but as I don't know for sure, I'll shut my trap on my opinions.


    What I would say is more so based on the facts. I'm not sure when Bill introduced the port fueler configuration, but I believe it was not long ago. Some installs happened on forged engines which I believe have lower pressure just from the build. Also, it seems that it's not an issue with the Hahn exhaust, so those too wouldn't see any issue (if this theory holds). The issue presents itself with a longer exhaust system and as of right now, I only know two who have that configuration right now and that is John and I. May be still present in shorter exhausts, but doesn't cause the problem.


    My question is, are other systems in place in the past, how much of the smoking issue was there because of the engine pressure and just no one figured on looking in that direction. I have no clue the answer as I'm not that up on these systems nor been around the Slingshot as much as you all have, but I do find the concept interesting.

    :00000436:
    Success is a lousy teacher. It seduces smart people into thinking they can't lose. - Bill Gates