Scosche Aftermarket Stereo Power Harness w/ OEM Backup Camera Integration for the Polaris Slingshot!

Attention Vendors. Please email robert@rabtech.com any instruction manuals you may have for your products. They will be added to the FILEBASE tab for members to access.
  • Easily Upgrade your Polaris Slingshot Stereo Receiver with this Plug and Play Stereo Power Wiring Harness with built in OEM Camera Integration Module. This harness allows you to pull 12V+ Full Time, 12V+ Ignition and Ground from the existing wiring harness that is behind the dash on all Slingshot models including the base model. It also allows you to integrate with the factory backup camera that came with your Slingshot so that you don't lose your backup camera functionality when adding an aftermarket stereo head unit that supports a camera input. The camera input to your head unit will be automatically triggered when you put your Polaris Slingshot in reverse because of our Plug and Play integration with the Reverse Trigger switch on the transmission bell housing.


    More information about this product can be found here: Polaris Slingshot Aftermarket Stereo Wiring Harness with OEM Backup Camera Integration :thumbsup:


  • well have a Pioneer head unit and sling mods told me they have had several reports with the older oem cam wireharness (which I have) and could never get working in my pioneer. When the scosche harness came out i called them and explained to them the $60 harness i purchased a few months ago never worked so Slingmods being the best company ever sent me a free scosche to try in my pioneer. Tomorrow I will install and see if it works.... if that fails, I also purchased a brand new Kenwood head unit that i will install and put slingmods theory to the test and see if it is a Pioneer issue or not.

  • well have a Pioneer head unit and sling mods told me they have had several reports with the older oem cam wireharness (which I have) and could never get working in my pioneer. When the scosche harness came out i called them and explained to them the $60 harness i purchased a few months ago never worked so Slingmods being the best company ever sent me a free scosche to try in my pioneer. Tomorrow I will install and see if it works.... if that fails, I also purchased a brand new Kenwood head unit that i will install and put slingmods theory to the test and see if it is a Pioneer issue or not.

    I don't agree with the statement about Pioneer head units from SlingMods to a point, lol


    I installed the harness and using a monitor without the pioneer wired in at all it does not work.


    With the schoche harness installed then reconnecting the stock radio the BU Cam does not work. It cycles the camera on and off when connected to stock radio, which is strange.


    Disconnect everything and go completely stock it works.


    I'm also annoyed because they told me the schoche was the same as the 2 separate harness they sell (power & BU Cam) and it's not. The separate harness contains wiring to install an over ride switch to activate the camera, the schoche does not.


    I walked away from it yesterday and I'm heading out in the garage shortly to work on it some more.

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS:

  • Under your backup camera settings you should have a couple options for the camera polarity. Which one did you select? Do not use the Slingmod harness with your factory head unit.

    When life knocks you down, calmly get back up, smile, and very politely say, "You hit like a bitch!"

  • Under your backup camera settings you should have a couple options for the camera polarity. Which one did you select? Do not use the Slingmod harness with your factory head unit.

    I choose the battery option.


    After many hours trouble shooting everything with the harness checks out. I'm wondering if maybe on the 2017 they changed the wiring slightly to accommodate the infotainment option available on the 2018 and retro fit option on the 2017. I'm wondering that because it acts like the camera is not getting power. When I switch into reverse, the Pioneer senses the reverse and I get a black screen on the Pioneer with the message stating the image may be reversed or similar. So it's registering the reverse trigger.


    I wish I knew for sure if the wiring was different. I will probably tear open the back of the sling to get to the camera and check to make sure its getting powered up when going into reverse. I tried gaining access via the shark fin brake light. I removed the top screw and lifted up the light assembly, but I'm not sure how the bottom attaches and I did not want to force it.

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS:

  • The stereo makes no difference at all. I can completely disconnect the head unit and use a standalone composite display and get the same results.


    You keep saying the problem is with Pioneer head units and its not. I guarantee you 1000% it is not the head unit.


    It's a Pioneer NEX 8200, but that makes no difference. Please believe me, do not blame it on the Pioneer.


    I can tap into the video signal from the OEM camera mounted into the back of the sling and get video. The signal is not making it from the back of the sling to the front.


    Yes, It's connect to the correct plug in the front of the sling in the dash.

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS:

  • @Casey_SS


    The unit itself would make a difference as Scosche did test with a pioneer unit which worked and yours didn't, so it appears to be some differences there.


    We also learned this morning that Pioneer System Settings by default have the camera settings to off, did you ever turns those settings on your head unit? Please let us know.

  • @Casey_SS


    The unit itself would make a difference as Scosche did test with a pioneer unit which worked and yours didn't, so it appears to be some differences there.


    We also learned this morning that Pioneer System Settings by default have the camera setters are off, did you ever turns those settings on your head unit? Please let us know.

    Yes, the settings are turned on in the Pioneer NEX 8200.
    I'm trying very hard to assist you and I'm not trying to be difficult. But please know IT IS NOT A PROBLEM WITH THE PIONEER RADIO/HEAD UNIT.


    Please re-read my post above. I can have the Radio/Head unit sitting on the bench not attached to the SlingShot and I get no video to a generic monitor that only has a composite video input. That same monitor can be connected to the rear of the slingshot spliced into the video output of the stock camera and I have a video signal from the camera. I connect it to the front wiring and no video signal.


    I believe the problem is with the wiring in the 2017 slingshot and changes made to accommodate the 2018 infotainment system.


    I'm here to help, if needed.

    John
    2017 SL LE Midnight Cherry
    :COILOVERSS::TURBOSS::MOTOROILSS::FILTERSS::COLDAIRSS::DONKEYSS: