I have a whining noise in the right angle drive​ (rear end).

    • RE: I have a whining noise in the right angle drive​ (rear end).

      Clueless wrote:

      Looking at RP compatibility chart looking at bottom half rp will work with most any base at first temp range

      RP_Ind_Technical_Appendix_Grease_Compatibility_Charts.pdf

      Sent from my Pixel XL using Tapatalk
      You seem to be REALLY concerned about this grease issue. Any particular reason why? Have you called Polaris or your dealer to ask what they recommend? Is there​ something I'm not getting?

      Sent from my Nexus 6P using Tapatalk

      "Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so."
      ― Douglas Adams
    • RE: RE: I have a whining noise in the right angle drive​ (rear end).

      Gadgeteer wrote:

      Clueless wrote:

      Looking at RP compatibility chart looking at bottom half rp will work with most any base at first temp range

      RP_Ind_Technical_Appendix_Grease_Compatibility_Charts.pdf

      Sent from my Pixel XL using Tapatalk
      You seem to be REALLY concerned about this grease issue. Any particular reason why? Have you called Polaris or your dealer to ask what they recommend? Is there​ something I'm not getting?

      Sent from my Nexus 6P using Tapatalk
      Just don't want to pump something in the u joint and it reacts wrong with the factory grease.

      Then I'm running at say 80 mph on highway when it seizes up. Would be ugly over $10 of wrong grease


      Sent from my Pixel XL using Tapatalk
    • I'm not the expert here but it sounds like there is not enough factory grease in the new u-joints to make much of a difference. Go with @'Gadgeteer''s advice and pump through a reasonable amount of new grease and you're good to go.

      I personally don't start a piece of equipment (tractor, excavator) without greasing it. If you don't see grease pumping through, you're not using enough. Not a lot, but some. U-joints don't require that level of maintenance but the same technique applies. Over greasing is not good but under greasing is, well, catastrophic!
      I've got money I haven't even made yet! :thumbup:
    • SlingLow wrote:

      I'm not the expert here but it sounds like there is not enough factory grease in the new u-joints to make much of a difference. Go with @'Gadgeteer''s advice and pump through a reasonable amount of new grease and you're good to go.

      I personally don't start a piece of equipment (tractor, excavator) without greasing it. If you don't see grease pumping through, you're not using enough. Not a lot, but some. U-joints don't require that level of maintenance but the same technique applies. Over greasing is not good but under greasing is, well, catastrophic!
      Exactly my plan with the RP grease and ordered the Lincoln needle thanks everyone for the information

      Sent from my Pixel XL using Tapatalk
    • I have a whining noise in the right angle drive​ (rear end).

      So needle arrived today. Amazon. Bigger then i thought and i already got the harbor freight grease gun

      The RP grease tube arrives later this week. All set for the weekend grease u joint and winterize slingshot

      Sent from my Pixel XL using Tapatalk

    Slingshotinfo.com is not affiliated with Polaris Industries the makers of Polaris Slingshot in any way.